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INTRODUCTION

GURPS Character Assistant (GCA) is a Microsoft® Windows® program designed
to assist players in creating characters for Steve Jackson Games’ GURPS® role-
playing game. While creating GURPS characters is not an overly complicated pro-
cess in itself, it can take a great deal of time due to constant point shuffling in an
effort to arrive at a satisfactory character within the allowed number of points.

GURPS Character Assistant is designed to be a friendly and attractive alternative
to the pencil, paper, and eraser mess that usually results when creating a character.
By using the program, you will be able to create characters in only a fraction of the
time that it used to take with a pencil and a calculator. You may even find that you
are able to make better characters, because you can see the results of changes to
attributes, advantages & disadvantages, skills and spells right away.

While GCA is generally a straightforward and easy to use program, there are many
features that are not easy to understand or find for people who are new to the
program. Because of this, we have written this quick introduction to the features of
GCA. This booklet does not attempt to explain all the functionality in deep detail,
but instead tries to quickly introduce to you the types of things of which GCA is
capable. It is our hope that users will experiment with GCA to better learn and
understand it’s capabilities.

SUPPORT

GCA is marketed mainly over the Internet, although we are slowly branching out
into certain other avenues of distribution. However, because our main thrust has
been electronic, we are not equipped to handle telephone support calls if you do
have trouble with GCA. If you have trouble, and need to contact us, we are avail-
able through the following avenues:

World Wide Web: http://www.teleport.com/~armin/gca/

Electronic mail: armin@teleport.com
ArminSykes@aol.com

U.S. mail: Miser Software
4130 SW 117th Avenue #401
Beaverton, OR 97005

The best way to reach us is through email, and we try to provide a prompt response
to all questions. If you have a problem, please be as specific in all details as pos-
sible to help us track down the cause.
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The best way to keep up to date with GCA in general is to visit our web site peri-
odically, and to subscribe to the mailing list for GCA. If you aren’t familiar with
mailing lists, or would like to know how to join, please follow the appropriate link
on the GCA web site.

WHEN GCA STARTS

The first window of importance you see when GCA starts up is the splash screen.
The splash screen covers up the main program window, and tells you that GCA is
running. Along the bottom of the splash screen is a status line that tells you what
GCA is doing as it loads.

The very first time you load GCA, it manually loads up the data file for the Basic
Set, 3rd Edition, Revised. After it loads that data file, it creates a FastLoad file. A
FastLoad file is a file that contains all the information from a set of data files,
specially formatted so that GCA can load it much more rapidly than it can normal
data files. Every time you change the data files that GCA uses in a particular data
file set (more on this later), GCA will want to create a FastLoad file for it. It is
definitely to your advantage to allow GCA to use the FastLoad files, since not
doing so will drastically increase the amount of time it takes to load GCA.

We’ll deal with loading data files more later. For now, let’s move on to take a look
at the basic features of GCA.

INTERFACE ELEMENTS IN GCA

Before we get too deep into the program itself, we should briefly touch on some of
the interface elements and conventions that GCA uses. GCA makes pretty heavy
use of some standard Windows elements, such as list boxes and buttons, but it also
makes use of a couple elements that you might not be quite as familiar with.

Spin buttons are special buttons that are split in half: the top half has an up arrow,
and the bottom half has a down arrow. You can click on either half, and generally
the up arrow raises a value, while the bottom arrow lowers a value.

Tabs are a handy way to show that there are several different parts of a window.
Tabs will look much like index tabs running across the top or bottom of a window,
each with a different name written on it. By clicking on the tab you’re interested in,
you can change the things in the window to match the tab you clicked.

Tables are large grid like elements that are divided up into rows and columns, like
a spreadsheet. GCA uses tables to allow you to edit one or more items at a time,
while seeing most of the information each item has. You can usually edit a spot on
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a table by clicking on it and typing in your new value, but there will sometimes be
certain columns of information that GCA won’t let you change.

USING GCA’S MAIN WINDOWS

GCA largely consists of seven main windows: one for attributes and two each for
advantages/disadvantages/quirks, skills, and spells. The Attributes window is the
most unique of the bunch, and we’ll deal with it separately below. The other main
windows in GCA are divided into two types: straight list windows, and category
windows. The straight list windows list items all in one list, showing everything
available for that type of item. For example, the Skills window shows all the skills
available to your character in one long list. The category windows, on the other
hand, break the available items down into different categories. For example, the
Skill Classes window shows the skills available to your character broken down into
the different classifications that GURPS has for skills, such as Animal, Artistic,
Athletic, etc. skills.

The Attributes Window

The Attributes window includes places for you to enter a name for your character
and yourself, as well as a way to adjust the character’s four main GURPS attributes.
There is also a check box for you to check once your character has begun play. The
major reason for the check box is so GCA can correctly keep track of attribute
costs when they double after the character enters play.

You can change the scores for the attributes by using the spin buttons next to the
attributes, or by directly entering the value for the score that you want.

The Other Windows

The straight list windows are generally pretty straightforward: along the left side
you have a list of the available items of that type, such as skills in the Skills win-
dow; this is called the Available list. Along the right side you have a list of the items
of that type which have already been added to the character; this is called the Se-
lected list.

The category windows are similar to the straight list windows, but they have one
additional feature: one or more rows of index tabs, similar to file folder tabs, run-
ning across the top of the windows. These tabs allow you to change between the
different categories within that type of item. To help differentiate within the pro-
gram between different types of categories, each type of window uses a different
name for them, but they all work the same way: ads/disads/quirks windows refer to
them as categories, skills windows refer to them as classes, and spells windows
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refer to them as colleges. When you click on a tab in a category window, the win-
dow will change to show you the information for the items in that category.

Note that it is possible in GURPS to have a single item listed under more than one
category, such as spells that are considered to be in more than one college. When
this happens, GCA will display the item under each category of which it is a mem-
ber. You still only have one item, it’s just listed in several places.

Another thing to note is that the Ads/Disads/Quirks windows are somewhat unique
in that they share a single window. Each of the windows for these items has a
special row of index tabs at the very top, which is how you can select between Ads,
Disads, and Quirks. In the category version of the window, the category index tabs
are displayed as a separate set of tabs below the main Ad, Disad, Quirk tabs.

Adding, Removing, Editing Items

Each of the windows, except the Attributes window, has a set of buttons on the
right side, below the list of your characters selected items. These buttons work the
same way in each window.

To add an item to your character, click on the item you want in the Available list so
that it’s highlighted, then click on the Add button. That item will be added to your
character. If you’ve added a skill, it is added with 0 points spent, so you’ll need to
add points. If you’ve added a spell, it’s usually added with 1 point spent in it. If
you’ve added an advantage, disadvantage, or quirk, it’s taken at the first level if it
has multiple levels, or just added if it doesn’t. You can also add items to your
character by double clicking on them in the Available list, pressing Enter while the
item is highlighted in the Available list, or dragging them from the Available list to
the Selected list.

To remove an item from your character, click on the item you want to remove in the
Selected list so that it’s highlighted, then click on the Remove button. That item
will then be removed from your character. You can also remove an item by pressing
Delete while the item is highlighted, or by dragging it from the Selected list to the
Available list.

To change the points or levels of an item that you’ve added to the Selected list,
click on the item that you want to change so that it’s highlighted, then use the spin
button located next to the Edit button to make your change.

If you want to change a selected item in some way other than just adjusting points
or levels, click on it to highlight it, and then click on the Edit button. GCA will pop
up an Edit window for the type of item that you selected, and you will be allowed to
change the name and other characteristics of the item. More on this later.
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Items with Prerequisites

If you experimented a bit during the section above, you might have noticed some-
thing odd: when you add spells to your character, GCA often adds more than one.
The reason for this is that, by default (meaning you can turn it off), GCA automati-
cally checks the items that you add to your character to see if they have any prereq-
uisite items. If they do, and your character doesn’t have them yet, GCA will either
add them automatically (if it can) or warn you that you’ll have to add them your-
self.

If GCA adds an item that has not had its prerequisites satisfied, or if GCA isn’t
sure, it marks that item with a little red ‘P’ next to the item.

Defaulted Skills

Another thing that you might have noticed if you’ve been experimenting is that
some skills will have little blue ‘d’ marks next to them. This mark means that the
skill is currently defaulting from another skill or attribute. In many cases, this marker
will go away when you add points to the skill. Sometimes, though, it’s more advan-
tageous to raise the skill from its default, so GCA will leave the ‘d’ marker there to
tell you that’s what’s happening.

Switching Between Windows

You can switch between GCA’s main windows by using the Windows menu. The
open windows are all listed at the bottom of the menu. If you close a window, either
intentionally or by mistake, you can open it up again by using the Recall options on
this menu also.

Many people prefer another option for switching between the windows. In the Pref-
erences window (select Preferences… from the File menu), click on the Appear-
ance tab to view the options for changing GCA’s appearance. If you check on the
Use Tab Strip for Main Windows option, and then click on Okay, GCA will display
a tab strip along the bottom of the main screen with a tab for each open window.
Clicking on the appropriate tab will move you to that window.

USING THE EDIT WINDOWS

When you press the Edit button on one of the main windows, you will be taken to
the Edit window, where you can edit the items you had highlighted in the Selected
list. GCA will show all of your selected items in a simple table format, with a wide
variety of columns that you can edit. There will always be a column or two that you
can’t edit (usually the level or points currently spent), but the others are generally
fair game.
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The different columns in the edit window all have different uses, but most of them
should be apparent. If you have questions about what the different columns do, you
can look in the GCA v2 Data File Format Specification (the FileSpec), which is
available on the GCA web site (there’s a link to it near the bottom of the Program
Files page). While the FileSpec deals mainly with writing data files, most of the
information it covers deals with the columns of the Edit window as well.

A couple of things that it is important to know about making changes in the Edit
window should be covered here, however. First, if you change the Name of an item,
GCA may not be able to find it again to apply the correct bonuses to it. GCA
applies bonuses to items based on their name.

Second, the Name Ext. column is mainly for your use, to differentiate between
similar names. Any text entered here appears within parenthesis after the name of
the item on your character. GCA only looks at the Name Ext. part of the name when
it’s told to by a particular bonus or adjustment. Common use for the Name Exten-
sion is to specify a specialization or particular concentration in a skill, such as
Guns (Pistol) or Survival (Plains).

Third, when you click on some items in the Edit window, the Mods button will
activate. Mods are similar in appearance to ads or disads, and they allow you to
apply enhancements and limitations to particular items. Clicking on the Mods but-
ton will call up the Mods window, where you can add the modifiers you’d like to
the item. When you close the Mods window, the specified modifiers will be ap-
plied to the item, affecting its cost.

USING OTHER DATA FILES

One of the features that makes GCA powerful is that you can load data files for
other GURPS books, or adaptations to GURPS from other sources. By choosing
which data files you want to load, you have more control over what types of items
are presented for use with your character.

In order to make use of other data files, you must tell GCA which files you want to
load. You do this in the Data Files tab of Preferences. To get to the Data Files tab,
you need to select the Preferences… option from GCA’s File menu. Then, click on
the index tab that says Data Files, and you’ll be there.

The Data Files tab is set up in three basic columns. Along the left side are some
drive and folder lists, so you can move around in your computer’s folders. In the
middle is a list of the data files (.GDF files) that are available in the currently
selected directory. On the right side is a list of the data files that are currently
selected to be used. Under the Selected Files list, you’ll recognize the two standard
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Add and Remove buttons, which let you add data files that you’ve marked in the
Available Files list, or remove files that you’ve marked in the Selected Files list.

While the Data Files tab is set up to make it easy for you to select the data files that
you want to use, you do have to use caution when selecting the files you want. First,
never select all the data files, as this will take forever to load, and most machines
don’t have enough memory anyway. Second, data files for newer books need to
come last on the list; in most cases this just means that you should place the
BASIC.GDF file first, the COMPEND1.GDF data file last, and your preferred
other data files in between. You don’t, of course, need to use these particular files,
but I hope you get the idea. The reason for the order is simply that newer books
sometimes contain the official, corrected versions of items from older books, so
they need to come later on the list to replace the earlier items correctly.

Note that every time you add or remove files from your list of files, GCA will have
to manually load all the data files and create a new FastLoad file. For this reason,
try to limit the number of times you need to change the data files. If you need to
switch files frequently, you should probably be using data file sets (see below).

Using Data File Sets

Simply adding or removing the data files you want as mentioned above will work
for many of you, but for others, you’ll need another level of control, because you
may have different sets of data files that you like to use for different campaigns.
For example, you might like to load BASIC.GDF, MAGIC.GDF, GRIMOIRE.GDF,
and COMPEND1.GDF for your fantasy game, and BASIC.GDF, MARTART2.GDF,
MASTYLES.GDF, and COMPEND1.GDF for your martial arts game.

GCA provides support for handling different sets of data files as well. On the Data
Files tab in Preferences, you’ll notice a small Data File Set button located on the
bottom left side, under the drive and folder list boxes. You can press this button to
open up the Data File Sets window, which allows you to create and select data file
sets.

The Data File Sets window is divided up similarly to the Data Files tab. The left
side has drive and folder list boxes to allow you to move around your folders, the
center shows the data file sets that you currently have available, and the right side
shows the data files that the currently selected set contains. At the top of the win-
dow is a text box that shows you the currently selected data file set.

If you want to create a new data file set, type the name you wish to use into the
Selected Data File Set text box, and if no file of that name already exists, GCA will
create a new set for you when you press the Okay button. Once you do press okay,
GCA will return you to the Data Files tab of the Preferences window, where you
will be able to add data files to your new set. Note: Keep in mind that GCA is
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currently a 16bit program, and does not support long filenames, so you should be
sure to keep the name of your new data file set at eight characters or less.

If you want to choose an already existing data file set, you can click on the set you
wish to use in the middle list, and the list on the right side will show you what data
files that set currently contains. If you find the set you like, click on Okay and GCA
will return you to the Data Files tab.

If you select a data file set, and you don’t need to change what files it contains,
GCA can usually use the FastLoad file that it originally created for that set, saving
you the time of loading all the files manually again.

If you find that you frequently change between data file sets, you can have GCA
ask you which set you intend to use every time you start up the program. On the
General tab of the Preferences window, simply check mark the Choose Data File
Set at Startup option.

How FastLoad Files Are Used

FastLoad files are created by GCA according to the name of the data file set that
you are using. By default, GCA created a data file set called DEFAULT.GDS for
you, and only put the BASIC.GDF file into it. You can add or remove data files
from that set, and when you do, GCA updates the FastLoad file for that set, which
is named DEFAULT.FST in this case. As long as all the files in the set are the same,
and none of the files have been changed on your hard drive, GCA will continue to
use the FastLoad file for the set you have selected, since it is much faster to load
than the normal method.

If you create a new data file set, GCA automatically creates a FastLoad file to
match the information in that set, so that if you switch back and forth between data
file sets, GCA can keep using just the corresponding FastLoad files, instead of
constantly having to reload all the files manually. Of course, if you edit or update
one of the data files that makes up a set, GCA will recreate the FastLoad file for any
sets that use the updated file.

VIEWING THE CHARACTER SHEET

Once you’ve made up your character, or while you’re making it up, you’ll probably
want to take a look at what its character sheet looks like. To do this, you’ll want to
use the Print Preview feature. To see the Print Preview, choose the Print Preview
option from the File menu, and GCA will run the print/preview program for your
character.
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Once the preview window opens, you’ll be able to see what your character sheet
will look like in its printed form, but without having to waste the paper.

At this time, GCA will only print on the default printer in Portrait orientation, on
letter size paper. To change the default printer, you can use the Print Setup option
on the File menu.

FILLING OUT THE CHARACTER

In addition to the main features of a GURPS character, such as skills and advan-
tages, there are other things that all many of us want for our characters, such as a
portrait and a description. You can add these things to your character by using the
additional parts of GCA available under the View menu.

Including a Character Portrait

You can add a picture of your character to the character sheet by using the Portrait
option under the View menu. When you select this option, the Character Portrait
window will come up. Click on the Load button to call up the dialog box that will
allow you to move around your drives and folders to find the picture you want to
use. Note that there is no preview feature here, so you’ll need to know what the
pictures are of, or just keep guessing and loading until you find one that you like.

GCA supports a variety of graphic types for use as character portraits, but the most
common ones are .GIF, .JPG, and .BMP.

If you want to get rid of the current portrait, just click the New button. Once you’re
finished, click Close to exit. When you close, the currently selected portrait will be
used for your character.

Including Character Description and Notes

You can add a brief character description or some notes about your character using
the Description or Notes options on the View menu. Note that both options open
the same window, but they open to different tabs on that window. You can change
between Notes and Description whenever you want to on this window just by click-
ing the appropriate tab.

Keep the amount of text that you enter here fairly minimal. GCA only supports
about 30k of text, and you can fill it up pretty quickly if you get on a roll.

Once you’ve entered the text you want, you can use the Close & Save button to
close the window and save your changes. If you messed up and want to return to
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whatever text you had before you opened the window, click the Close & Abort
button to avoid saving your changes.

Miscellaneous Items

Selecting the Misc option on the View menu will call up a window that allows you
to change certain other items that appear on the character sheet. These miscella-
neous items include: character race, unspent character points, body protection fields,
and parry and block figures.

Most of the items on this page are simple text fields in which you can enter what-
ever values you feel are appropriate. Keep in mind the amount of space you have to
show this info on the character sheet, though, and don’t write too much in places
like Other PD.

The Parry Using… and Block Using… items allow you to set how GCA displays
the Parry and Block areas on your character sheet. Select the appropriate skill in
each place, and then mark the multiplier that should be used. For example, you can
select the Broadsword skill from the list, and mark the at… 1/2 Skill option. Note
that GCA only shows the skills that you have already chosen in the dropdown lists,
so you can’t select a skill here for GCA to add to your character.

Packages

GCA supports a type of special item called a package. A package is basically just
a list of items that will be added to your character when you take the whole pack-
age. Right now, packages are used mainly for races and martial arts styles. You can
use the Packages option on the View menu only when you’ve already loaded a data
file, such as FFRACES.GDF or MASTYLES.GDF, that includes packages. GCA
does not support the ability to create packages from within GCA.

In the Packages window, you’ll see the familiar layout, with available packages on
the left and selected packages on the right. This window also has tabs, so if you
have a lot of packages available you can view only the types in which you are
interested. Note that the first tab shows the complete list of all available packages;
GCA only has one window for packages, so we made the complete list available as
a separate category.

When you add a package to the character, all the items of that package are added
also. When you remove a package, all the items of the package are also removed.

One thing that a package can do that isn’t restored when you remove the package is
change your attributes scores. GCA has no way of know if a straight attribute change
was done by you or a package, so it leaves it alone. Bonuses to attributes, though,
are removed correctly if the bonus came from a package.
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Encumbrance and Equipment

Right now, GCA does not support any way for you to check off which encum-
brance level you’d like displayed on your character sheet.

GCA does not support equipment at this time, either.

USER DEFINED ATTRIBUTES OR STATISTICS

GCA supports the ability for data files to create new attributes for characters, or to
redefine the attributes already in use.

If you load a data file that includes new or redefined stats, and you want to use
those stats with a previously created character, you must use the Reintegrate Stats
option on the Tools menu to replace the stats the character already has with the
ones defined in the currently loaded set of data files. This is the only way, short of
recreating the character from scratch with those files loaded, that you can add new
stats defined in a data file to your character.

GCA also supports the ability for packages to create new attributes, or to redefine
attributes. Adding a package to a character will implement the changes specified,
or add the new stats specified. You do not need to Reintegrate Stats when the stats
are added or changed by a package that you’ve added to the character.
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